Why USB flash drives are not detected on Kiosk Mini

Issue

In some cases, MetaDefender Kiosk Mini does not detect USB flash drives when plugged into any of its ports.

Cause

This issue may be related to intermittent instability in the USB hub hardware that prevent proper USB device detection

Solution

Restart the Kiosk Mini device:

  1. Connect a physical keyboard and press Alt + S to exit Kiosk UI, then safely shutdown or restart the device
  2. Power the device back on
  3. Plug in the USB flash drive to test again

If the connected keyboard is not detected, you may need to forcefully shut down the device by pressing and holding the power button located on the back of the unit.

If you have any difficulty Accessing and Using Kiosk Administrative Controls Or the Kiosk Itself Due To Unresponsive Keys, please follow these instructions on How To Create a Support Package, before creating a support case or chatting with our support engineer.

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