Why is Clam AV not scanning files after configuration changes?

This article applies to MetaDefender Core releases deployed on Windows and Linux systems.

Issue

Clam AV antivirus engine is not scanning some files after configuration changes. Files submitted at the time of configuration changes are processed without scanning by Clam AV.

  • The Metascan verdict for Clam AV during this time is “Not scanned”.

Root Cause

The Clam AV daemon (background process) needs to restart to apply configuration changes (after enabling/disabling some options in Clam AV's configuration).

During this restart, the Clam AV engine is uninitialized, causing files submitted during this time to not be scanned by the engine. This behavior is normal and expected.

Resolution

Understand that when configuration changes are made to Clam AV, the daemon restarts, temporarily disabling scanning.

  • If scanning by all AV engines is preferred, avoid submitting files for scanning during the daemon restart period.
  • If a file is submitted during this time, it will not be scanned by Clam AV - it would still be scanned by other AV engines, and scanning will resume normally once the daemon is fully restarted.
  • No further action is required as this is expected behavior.

If Further Assistance is required, please proceed to log a support case or chat with our support engineer.

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