Why can't I generate a support package even when running the script as an administrator?

This article applies to all Email Gateway Security releases deployed on Windows systems.

Scenario:

You may encounter the error "A subdirectory or file info already exists." when running the script mdemailsecurity-collect-support-data.bat, as shown in the image below, even if you have administrative privileges.

Root Cause:

When the script runs, it creates temporary folders named "info", "config", and "log". However, these folders may already exist from a previous run.

Resolution

If you encounter this issue, follow the instructions below.

Step 1: Open Command Prompt (CMD) with administrative privileges.

Step 2: Navigate to the Email Gateway Security directory using the command below.

  1. cd C:\Program Files\OPSWAT\MetaDefender Email Security

Step 3: Run the batch script mdemailsecurity-collect-support-data.bat. This script will force the creation of a new support package regardless of whether old temporary folders exist, and it will clean up any existing folders.

_the script will force to generated new support package_

the script will force to generated new support package

_the old temporary folders are removed after running the script_

the old temporary folders are removed after running the script

If Further Assistance is required, please proceed to log a support case or chatting with our support engineer.

Type to search, ESC to discard
Type to search, ESC to discard
Type to search, ESC to discard