Disk Is Almost Full. Used: 100%
Issue
The notification bar shows the following message: "Disk is almost full. Used: 100%"
After this message is shown, the Drive will take longer than usual to perform another scan. In some cases, it doesn't boot the next time.

Cause
After using MetaDefender Drive for long scans or with large archive files, the temporary working space of the Drive is filled up. MetaDefender Drive can't function properly if the temp data isn't flushed.
This issue has been reported for the OPSWAT MetaDefender Drive USB Flash version, which has a limit of working space of around 21 GB.
Solution
You need to your MetaDefender Drive using MetaDefender Drive Toolkit. It will flash your Drive with its current or latest software version and keep your previous scan reports.
Please follow the instructions to download and use the MetaDefender Drive Toolkit: https://docs.opswat.com/mddrive/advanced-usages/drive-toolkit.
To prevent the issue from happening again in the future
Since MetaDefender Drive USB Flash has 21 GB available for the temporary working space, please plan your scans with less than 21GB of data per session.
You can also adjust your Archive Handling and Scan Settings from Preferences → Settings to achieve optimal performance and reduce the chances of this issue happening:

Adjust how MetaDefender Drive handles archive files

Adjust the settings for max file sizes and timeouts